1998 dodge avenger problem need help.

  • rletendre
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
1 week 1 day ago - 1 week 1 day ago #203569 by rletendre
1998 dodge avenger problem need help. was created by rletendre
Hello, so i have a 1998 dodge avenger 2.5l v6 with the automatic transmission. So the problems i'm having with this vehicle are, first it starts fine when cold, but after it gets warmed up and sits for about 10 minutes or so i have to crank the engine over at least 3 times before it starts again, also stalls if i slam on the brakes hard. 2nd problem is when i hold the accelerator pedal down at 2,000 rpms the engine starts to have a random misfire code triggered, it also triggers randomly while driving. it does shift fine through all the gears, also at idle the cars rpms bounces from around 800 to 700 constantly. Things i have done already. I did a compression and leak down test, all cylinders where at around 150 psi 1 or 2 pounds off nothing dramatic. I replaced the distributor, spark plugs, plug wires, iac valve, throttle body, throttle position sensor, crank position sensor, throttle body gasket, new oem injectors, new fuel pump, new original oem exaust system cats and all with new 02 sensors and gaskets, i also replaced the cars computer with a refurbished one. timing belt, tensioners and water pump.I also checked for vacuum leaks and didn't find any. So not too sure what could be causing the weird idle and random misfires and stalling when slamming on the brakes? any help would greatly be appreciated.
Last edit: 1 week 1 day ago by rletendre. Reason: forgot to add an item

Please Log in or Create an account to join the conversation.

Advertisement
More
1 week 1 day ago #203570 by relative4
Replied by relative4 on topic 1998 dodge avenger problem need help.
How did you check for vacuum leaks? Have you tested the brake booster for leaks? What are your fuel trims at idle, 2500, and 4000 RPM?

Please Log in or Create an account to join the conversation.

  • rletendre
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
1 week 1 day ago #203572 by rletendre
Replied by rletendre on topic 1998 dodge avenger problem need help.
I used a smoke machine into the brake booster line going into the intake manifold. And i will check again on the fuel trims, but when i last checked them a couple of months ago i believe it was within spec according to my manual, but will update those again in the morning. I have not tested the brake booster for leaks as well. Will do that in morning as well and will update asap. Thanks again.

Please Log in or Create an account to join the conversation.

  • rletendre
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
4 days 14 hours ago #203589 by rletendre
Replied by rletendre on topic 1998 dodge avenger problem need help.
Sorry for the late reply work got ahead of me, the fuel trims for long term at idle is 0.0 and 0.0 and short terms are at -19.2 and -18.5 not able to check at different rpm ranges as my obd scanner only works at idle.

Please Log in or Create an account to join the conversation.

  • rletendre
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
3 days 10 hours ago #203594 by rletendre
Replied by rletendre on topic 1998 dodge avenger problem need help.
Ended up figuring it out. When i did the timing belt the back cam spun a little too far and timing was off by 2 teeth.

Please Log in or Create an account to join the conversation.

Advertisement
Time to create page: 0.265 seconds