2001 Camry 2.2l Stalling/Stumble in Closed Loop Issue

More
2 weeks 23 hours ago #203521 by pace507
I have cleaned TB, IAC, replaced ECT, changed plugs and wires. Plugged the EGR vac line, tested EGR valve with pump to make sure working. I have changed the 2 cats, replaced the upstream O2 sensor, smoke tested. If the car goes into closed loop it will randomly stumble idling and usually stall. Only if RPM below say 900rpm. Just stared out of the blue.

If I unplug the o2 sensor it seems to run fine as I assume it is in a open loop at that point. Also same with MAP sensor. If I plug back in, while it is warmed up, I am assuming it goes to closed loop and then it will stumble and die. Intermitently but usualy within a few minutes of idling.

Of course there are no codes yet. Just checking to see if anyone has any ideas. I am going to replace MAP sensor (junkyard part just in case), I plan on replacing Camshaft Position Sensor and testing fuel pressure.

It always starts right up after it dies, without any issue at all.

Any help would be great, have been trying to narrow this down. I have followed many other threads on other forums and the end result is the owner just sells the car, ha.

It has 175k on it, I bought from a private party and have records of service, it was pretty well maintained.

Any help would be great.

Please Log in or Create an account to join the conversation.

Advertisement
More
1 week 6 days ago #203531 by college man
With a scanner you would need to see what the fuel trims and the o2 sensor are doing at the time of the problem.

Believe it or not Iam trying to help you.

Proud to be Eric The Car Guy Certified.

Over 10,000 posts strong.

Mobil1 New Jersey highway tested everyday.

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #203532 by pace507
Thanks I will get that data and record it. I swapped the map sensor and are updating my scan tool. I will grab the data and see. the 02 sensor was replaced the upstream with a denso brand one. I will grab as much data as I can as I am not 100% familiar what all the acronyms are and will post it tomorrow.

thanks

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #203535 by college man
cool. keep us posted.

Believe it or not Iam trying to help you.

Proud to be Eric The Car Guy Certified.

Over 10,000 posts strong.

Mobil1 New Jersey highway tested everyday.

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #203537 by pace507
Here is a video of it before it dies and at the end it dies as you can see the MAP PSI goes to 13. It stumbles first catches itself and then dies out. Only thing I noticed is the o2s b1 s2 goes to 0 volts not sure if it did that before it stumbled or during the stumble at the end it shows voltage.

Here is link to video.

1drv.ms/v/s!Ap6V41GIXD8Gh7JbAUBuPHFNuRhr7Q?e=rANzpl

Let me know

Please Log in or Create an account to join the conversation.

Advertisement
More
1 week 6 days ago - 1 week 6 days ago #203538 by pace507
More I look at it I am leaning towards maybe a fuel pressure regulator maybe stuck or something? It always runs in open loop just closed. I can't imagine it would be a fuel pressure related, but more of the damper?
Last edit: 1 week 6 days ago by pace507.

Please Log in or Create an account to join the conversation.

Time to create page: 0.250 seconds