Horn is not working

  • mirageservo
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
5 months 3 weeks ago - 5 months 3 weeks ago #200173 by mirageservo
Horn is not working was created by mirageservo
Hi Guys,

I have a problem here, I'm pretty sure I know but I'm 100% confused, I have rewired my horn electrical same to the attached below, but it seems not to work, I suspect because there is no supply for 86? If that is the case the supply should come from where or where do I need to splice and add the source?

If there is something else, please help point it out.

This is a product of an entire rewire project on a Nissan B12



Nissan B12
E16
5 Speed Manual

Stay Dirty!

Mirage
Attachments:
Last edit: 5 months 3 weeks ago by mirageservo. Reason: Formatting and Clarity

Please Log in or Create an account to join the conversation.

Advertisement
  • nightflyr
  • nightflyr's Avatar
  • Away
  • 6th Gear
  • 6th Gear
  • 2002 Nissan Xterra 3.3L 4X4
More
5 months 3 weeks ago - 5 months 3 weeks ago #200174 by nightflyr
Replied by nightflyr on topic Horn is not working
I'm assuming the horn switch you have connected to post 86 is switch to ground when pressed.
I believe that is where your having the issue.

You should be only supplying +12V to the control side of the relay, not any ground
Attachments:
Last edit: 5 months 3 weeks ago by nightflyr.

Please Log in or Create an account to join the conversation.

  • mirageservo
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
5 months 3 weeks ago #200177 by mirageservo
Replied by mirageservo on topic Horn is not working
With regards to the diagram, if I understand correctly, 86 will be hot? like the diagram below:



Mirage
Attachments:

Please Log in or Create an account to join the conversation.

  • mirageservo
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
5 months 3 weeks ago - 5 months 3 weeks ago #200178 by mirageservo
Replied by mirageservo on topic Horn is not working
On a nutshell, is this the one we should aim for?



Mirage

PS, Disregard the missing Fuse for Post 30, its there but not in the diagram :)
Attachments:
Last edit: 5 months 3 weeks ago by mirageservo.

Please Log in or Create an account to join the conversation.

  • mirageservo
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
2 months 3 weeks ago #201312 by mirageservo
Replied by mirageservo on topic Horn is not working
Hello,

Based on the car user's manual, the following is the OEM wiring diagram



Here is the diagram of the existing wiring



My concern is that, if I press the horn button on the steering wheel, nothing is happening but if I ground #85 the horn will go on immediately even without pressing the horn button

What is wrong or what am I missing?

Thank you
Attachments:

Please Log in or Create an account to join the conversation.

Advertisement
  • relative4
  • relative4's Avatar
  • Away
  • 6th Gear
  • 6th Gear
More
2 months 3 weeks ago #201313 by relative4
Replied by relative4 on topic Horn is not working
If the 'S' in the red wire on the left is the horn button/switch, then you have the relay mis-wired. Rotate the relay 90 degrees in that diagram, and you should be good to go.

Please Log in or Create an account to join the conversation.

  • mirageservo
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
2 months 3 weeks ago #201314 by mirageservo
Replied by mirageservo on topic Horn is not working
Sorry its not, its a fuse

Please Log in or Create an account to join the conversation.

  • nightflyr
  • nightflyr's Avatar
  • Away
  • 6th Gear
  • 6th Gear
  • 2002 Nissan Xterra 3.3L 4X4
More
2 months 3 weeks ago #201315 by nightflyr
Replied by nightflyr on topic Horn is not working
There are two configurations when using a 5 pin relay that will work depending on if your steering wheel horn switch is switching power or ground..
You need to confirm which yours is.

Attachments:

Please Log in or Create an account to join the conversation.

  • relative4
  • relative4's Avatar
  • Away
  • 6th Gear
  • 6th Gear
More
2 months 3 weeks ago #201316 by relative4
Replied by relative4 on topic Horn is not working

mirageservo wrote: Sorry its not, its a fuse


So where's the switch?

Anyway, the relay is still wired sideways.

Please Log in or Create an account to join the conversation.

  • mirageservo
  • Topic Author
  • Offline
  • 1st Gear
  • 1st Gear
More
2 months 3 weeks ago #201328 by mirageservo
Replied by mirageservo on topic Horn is not working
Thank you nightflyr, the negative trigger diagram was what I need.

Please Log in or Create an account to join the conversation.

Advertisement
Time to create page: 0.395 seconds